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About this manual 

Welcome to IBM® Rational® DOORS® for HP Quality Center Interface.

Rational DOORS for HP Quality Center Interface allows you to synchronize 
data between Rational DOORS, the world’s leading requirements management 
solution, and HP Quality Center, an integrated enterprise application for 
organizing and managing the entire testing process. You can transfer 
requirements in Rational DOORS to an HP Quality Center project, and transfer 
tests and defects between HP Quality Center and Rational DOORS. You can 
access Rational DOORS requirements information using your HP Quality 
Center interface, and access HP Quality Center test and defect information using 
your Rational DOORS interface.

This document describes how to use version 3.6 of Rational DOORS for HP 
Quality Center Interface and the administration console. It assumes that you 
know how to use both Rational DOORS and HP Quality Center.

Typographical conventions

The following typographical conventions are used in this manual:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus. For example: Click Yes to continue.

Courier Commands, files, and directories; computer output. For 
example: Edit your .properties file.

> A menu choice. For example: Click File > Open. This means 
click the File menu, then click the Open command from it.
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Related documentation

The following table describes where to find information in the documentation 
set:

For information on See

How to install Rational DOORS for HP 
Quality Center Interface

The Rational DOORS Information 
Center

How to use Rational DOORS The Rational DOORS Information 
Center

What’s new in Rational DOORS for HP 
Quality Center Interface

The download document

How to set up licenses to use Rational 
DOORS for HP Quality Center Interface

Managing licenses with Rational 
Common Licensing

http://pic.dhe.ibm.com/infocenter/doorshlp/v9r5m2/index.jsp
http://pic.dhe.ibm.com/infocenter/doorshlp/v9r5m2/index.jsp
http://pic.dhe.ibm.com/infocenter/doorshlp/v9r5m2/index.jsp
http://pic.dhe.ibm.com/infocenter/doorshlp/v9r5m2/index.jsp
http://www.ibm.com/support/docview.wss?uid=swg24036297
http://pic.dhe.ibm.com/infocenter/rational/v0r0m0/index.jsp
http://pic.dhe.ibm.com/infocenter/rational/v0r0m0/index.jsp
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1 Analyzing your data

• User roles

• Data architecture

• Common attribute maps

• Working with synchronization tasks

• SoQ attributes

User roles

Rational DOORS for HP Quality Center Interface provides a unique, role-based 
approach to systems integration. The roles addressed include the Analyst, the 
QA/Tester, and the Analyst Manager.

Analysts

Analysts working in Rational DOORS are interested in developing requirements 
that can be satisfied by both development and test. If requirements need to be 
verified through testing, the Analyst creates qualification criteria, which detail 
the testing that is required. By using the integration, the Analyst can monitor that 
test planning covers all of the original requirements and can interrogate the test 
plan to check that it meets the qualification criteria. Once testing begins, the 
Analyst can monitor the requirements for associated defects that have been 
raised against tests that have failed. The analyst can identify full business impact 
for defect resolution against the original customer demand.

QA/Testers

QA/Testers working in HP Quality Center are interested in test development 
and test execution. QA/Testers take the qualification criteria as their 
requirements and develop tests to meet them. Tests are associated back to the 
requirements so that a review can take place to make sure that all of the defined 
objectives have been met.

Analyst Managers

Analyst Managers working in Rational DOORS are interested in finding if tests 
have been successfully developed and then executed against the original 
requirements. Initially managers are only interested in a true or false answer to 
distinguish if a requirement can be considered qualified. As a manager needs to 
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perform analysis on why a requirements has not been successfully tested, more 
detail is needed. This detail is provided by the Statement of Quality (SoQ) 
reports that are generated using Rational DOORS for HP Quality Center 
Interface.

Overall benefits

The Analyst Manager understands the full business impact of releasing a system.

The Analyst can focus on providing testable requirements, and can be involved 
in prioritization of defects dependent on business impact.

The QA/Tester can test against a defined set of requirements instead of testing 
what is built.

Data architecture

Traditional integrations between two products often make the assumption that a 
subset of information can be synchronized and replicated into two different 
databases. While this integration is intended to be used on enterprise scale data, 
it cannot do this by simply scaling the amount of information that is replicated; 
there is no magic solution on how to duplicate gigabytes of information. Rather 
than take this normal approach of data duplication, the integration requires the 
organization to perform some analysis on their data architectures in order to 
identify one or more subsets of information that need to be available in both 
Rational DOORS and HP Quality Center.

Data analysis starts with questions:

1. What information in Rational DOORS makes up the qualification criteria 
that should be displayed in the requirements pane in HP Quality Center? 
How does the tester know what to test and when to consider that a test 
needs to pass?

2. What information in HP Quality Center should be displayed in modules in 
Rational DOORS? Each different type of information seen in HP Quality 
Center will be transferred into one or more Rational DOORS modules.

The answers to these questions are not as obvious as it appears. The fact that the 
integration can synchronize a certain type of information does not mean that it 
should. Consideration of the other aspects of the integration should be taken 
into account before data analysis can be considered as complete. For instance, 
SoQ attributes are designed to reduce the amount of information that needs to 
be explicitly synchronized.
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Common attribute maps

Common attribute maps

Rational DOORS for HP Quality Center Interface uses the concept of attribute 
maps as the basis for synchronizing Rational DOORS and HP Quality Center. 
Attribute maps are the relationships between Rational DOORS attribute types 
and HP Quality Center field types.

Data is transferred between the attributes and fields that are mapped. When you 
map attributes, you must make sure that the attribute type in Rational DOORS is 
compatible with the field type in HP Quality Center. For example, you might set 
up a relationship between a string attribute type in Rational DOORS and a string 
field type in HP Quality Center. This mapping would allow the data to be shared 
between the two.

When you begin to plan the mappings between different modules in Rational 
DOORS and HP Quality Center, you quickly realize that many of the mappings 
are similar. For example, the attribute types in a Rational DOORS module that 
map to the field types in an HP Quality Center entity are similar, if not the same, 
as those between other modules and entities.

To take advantage of this fact, Rational DOORS for HP Quality Center Interface 
uses common attribute maps to allow you to set up the relationships between 
Rational DOORS and HP Quality Center quickly and easily.

When you set up your common attribute maps, they are used to organize your 
synchronization tasks. For example, if you have four synchronization tasks that 
use the same common attribute map, they are displayed under it (almost as if the 
common attribute map were a folder).

For more information about synchronization tasks, see the administration 
console’s online help.

Working with synchronization tasks

Before you start to use Rational DOORS for HP Quality Center Interface, you 
must spend some time analyzing what information needs to be visible in both 
Rational DOORS and HP Quality Center. Once you have done this, care is 
needed to break this information down and develop a synchronization strategy.

To do this effectively, you need to understand the scope of information. Scope 
can be understood to be the combination of three elements:

• Information category

You may want to integrate requirements, tests or defects.

• Volume of information
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How much of the information in a category needs to be seen in both 
Rational DOORS and HP Quality Center.

• Attribute ownership and mapping

Which tool can modify data and how this information is seen by the 
secondary tool.

You need to understand the scope of information before you define it with one 
or more synchronization tasks. Synchronization task definitions establish rules 
by which the integration will function. It is not necessarily the case that only one 
synchronization task should be used to describe the complete scope of 
information.

Performance of the integration is governed by the overall size of a 
synchronization task and the amount of data that has been modified since the 
last synchronization. Where possible, task definition should restrict the overall 
volume of data by constraining both the filter used and the number of attributes 
considered. A second strategy for task definition is to consider the amount of 
data that is being modified. If it is known that an area of information is 
infrequently subject to change and a different area of data is far more volatile, 
split the task definition into two, with one task being synchronized less 
frequently than the other.

Note: Elements are created during a synchronization task, where Rational 
DOORS is configured to run as master and HP Quality Center is run as slave. If 
you log in to HP Quality Center client and delete the elements that are created in 
the synchronization task and re-run the synchronization again, the metadata  files 
get corrupted in HP Quality Center client. 

Improving performance of synchronization tasks

Rational DOORS for HP Quality Center Interface gives you a number of 
different ways to improve the performance of synchronization tasks. You can set 
up your system so that it performs the following tasks:

• Running synchronization tasks in chunks

• Running synchronization tasks in parallel

• Running synchronization tasks in parts

• Running synchronization tasks at specific times

Running synchronization tasks in chunks

If you have a synchronization task that contains a large number of objects to be 
processed, you can break it down into “chunks”, and run each chunk in parallel. 
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Working with synchronization tasks

There are settings that allow you to determine the maximum number of chunks 
that can run in parallel and the maximum number of objects in each chunk. For 
example, if you have a synchronization task that processes 5,000 objects, you can 
set your system to run a maximum of five chunks in parallel, with each chunk 
containing a maximum of 1,024 objects. When the synchronization task is run, 
five separate processes of 1,024 objects are run in parallel. Instead of carrying 
out 5,000 processes one after the other, your system can carry out the 5,000 
processes in a much shorter time.

Running synchronization tasks in parallel

As well as being able to break down synchronization tasks into different chunks 
that can then be run in parallel, you can also set up your system to run the 
synchronization tasks themselves in parallel. The number of synchronization 
tasks that you can run simultaneously is determined only by your hardware.

You can also prioritize your tasks, making sure that the most important tasks are 
always run first.

Note  The integration does not execute synchronization tasks in 
parallel if those tasks have end points that are located in 
different Rational DOORS databases. The synchronization 
tasks are completed in one database before tasks in another 
database are started.

Running synchronization tasks in parts

As well as being able to break down synchronization tasks into chunks and then 
running the synchronization tasks themselves in parallel, you can also select to 
run only parts of a synchronization task.

Each task is now broken down into three separate parts:

• Content

The content part of the synchronization task refers to changes to the data 
that need to be synchronized, for example straightforward changes to the 
text in a requirement.

• Structure

The structure part of the synchronization task refers to changes to the 
hierarchy of the objects in the task, for example when objects are created, 
moved, or deleted.

• Links
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The links part of the synchronization task refers to changes to the links in 
and out of the objects in the task.

For example, if you know that a synchronization task very rarely contains 
changes to the structure or to links, you can split it into two tasks: one task that 
processes only changes to the content, and a separate task that processes the 
changes to the content, the structure, and the links. You can then run the first 
task every night, and run the second task every week.

Running synchronization tasks at specific times

Finally, there is a setting that allows you to set up a specific time during which a 
synchronization task is run. By entering a start time and end time, you can make 
sure tasks are not run when you need to have access to your databases to carry 
out other tasks. Typically, synchronization tasks are run overnight; you can use 
the start time and end time to make overnight runs the only time when 
synchronization tasks can be run.

This time is set per database.

Determining the best strategy for your synchronization tasks

The decisions about running synchronization tasks in chunks, in parallel, in 
parts, and at specific times, are determined by your specific set up, and the 
number and size of your synchronization tasks. If you only run a small number 
of tasks that process a small number of objects, it might make sense for you to 
simply set up the synchronization tasks to run sequentially. If, on the other hand, 
you have a large number of tasks that process a large number of objects, 
investing the time in determining the best way to organize the running of your 
tasks is time well spent.

For more information about synchronization tasks themselves, see 
“Understanding synchronization tasks,” on page i.

SoQ attributes

Task synchronization is not the only way to retrieve HP Quality Center 
information into Rational DOORS and display it alongside the requirements. 
SoQ attributes have been defined to provide three levels of reporting against the 
original qualification criteria. SoQ attributes are produced as a report with the 
assumption that this reporting is only done at milestones in a project and not 
more frequently. If a report needs updating, it must be recreated.

The three levels of report include:

• SoQ Value
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SoQ attributes

A single statement against each requirement describing if the requirement 
and its children can be considered as qualified or not. As the report is 
produced a defined test set within HP Quality Center is used to interrogate 
the state of testing at a particular time.

• SoQ Defect

A slightly more verbose version of SoQ Value. Where a non-qualified 
requirement has associated defects within HP Quality Center, information 
about the defect is reported alongside the requirement itself. The Analyst 
can now determine if the priority of the defect has been set to indicate the 
business impact on the defect if it is not resolved at time of release.

• SoQ Report

An extension to SoQ Defect providing a mini-report on TestRuns run 
against each requirement in the module. This report provides a summary of 
testing and the level of defects that have been raised against a requirement.

For more information about SoQ attributes, see “Creating SoQ Attributes,” on 
page i.
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1 Understanding synchronization tasks

• About synchronization tasks

• What information can be transferred?

• About synchronization task components

• REQUIREMENTS entities and synchronization tasks

• TEST entities and synchronization tasks

• DEFECT entities and synchronization tasks

• Naming synchronization tasks

• About mapping attributes and fields

About synchronization tasks

Before you start creating synchronization tasks it is important that you analyze 
the data that needs to be available in both Rational DOORS and HP Quality 
Center. You should be aware that the amount of information that is transferred 
by a synchronization task and the frequency with which that data is modified will 
impact on the decision you take about how to set up your synchronization tasks. 
For more information about what you should consider before creating your 
synchronization tasks, see “Analyzing your data,” on page i.

Each subset of data that you want to transfer should be defined by either a 
module filter that is saved as part of a view, or as an HP Quality Center favorite. 
These views and favorites can be selected when you create the synchronization 
tasks and this is how you define the data that is to be transferred. The Rational 
DOORS view must also have any attributes that you want to be available to the 
integration displayed in columns.

For each view or favorite that you have created, you must create a 
synchronization task. A synchronization task comprises mappings between the 
attributes in a Rational DOORS module and fields in an HP Quality Center 
entity. The synchronization task binds a Rational DOORS module to an HP 
Quality Center entity and defines the rules that will govern the transfer of the 
data between the databases.
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What information can be transferred?

The integration can move data between the REQUIREMENTS, TESTS and 
DEFECTS entities in HP Quality Center and any number of Rational DOORS 
modules.

For each entity, one or other application must be the controlling application. The 
controlling application is the application that controls the creation and deletion 
of objects. So, if you have five synchronization tasks that define information that 
is to be transferred between the TESTS entity and Rational DOORS, all five 
must specify the same application as the controlling application.

Rational DOORS must be the controlling application for the 
REQUIREMENTS entity and typically HP Quality Center will be the 
controlling application for the TEST and DEFECTS entities. Using Rational 
DOORS and HP Quality Center in this way enables the Analyst to use SoQ 
attributes to interrogate the HP Quality Center database from Rational DOORS 
and retrieve varying levels of information about the state of testing for the 
project.

For Rational DOORS to be able to retrieve this information, you must create 
synchronization tasks for both the REQUIREMENTS entity and the TEST 
entity. The synchronization tasks for the REQUIREMENTS entity should 
define the qualification criteria for the project. Once the qualification criteria 
have been transferred to HP Quality Center as requirements, the QA/Tester can 
begin creating tests and associating the tests with the requirements that they 
verify.

HP Quality Center provides a function by which tests can be created 
automatically from requirements. This has two main advantages for the 
integration:

• If you have created the qualification criteria in Rational DOORS in a 
hierarchical structure, that structure is copied when the tests are created. 
Non-leaf objects are created as folders in the TEST entity and leaf objects 
are created as tests. When the analyst in Rational DOORS creates SoQ 
attributes to determine the status of the project, the values for the leaf 
objects are propagated up through the hierarchy, so the analyst can get a high 
level statement of quality for the project as a whole. More detailed 
information can be viewed by navigating down through the hierarchy in 
Rational DOORS.

• Associations are created automatically from the tests to the requirements 
when the tests are created. The integration relies upon the creation of 
associations to retrieve and present testing information to the Analyst using 
the SoQ attributes.
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About synchronization task components

If you want Analysts to see data from the DEFECTS entity in Rational DOORS, 
you can create synchronization tasks to transfer this information. Again care 
should be taken when analyzing what information needs to be transferred so that 
you can maximize the performance of the integration. Remember that the 
analyst can retrieve information about the defects that impact the project using 
SoQ attributes, so it may not be necessary to create synchronization tasks for the 
DEFECTS entity.

About synchronization task components

For each subset of information you want to transfer between Rational DOORS 
and HP Quality Center you must create a synchronization task comprising 
mappings between the attributes in a Rational DOORS module and fields in an 
HP Quality Center entity. You map attributes in Rational DOORS to fields in 
HP Quality Center. Data is transferred between the mapped attributes when the 
synchronization task is run.

Rational DOORS

To set up a Rational DOORS module for synchronization, create the Rational 
DOORS view. The view should contain columns for each of the attributes you 
want to make available for mapping. If Rational DOORS is to be the controlling 
application for the entity, for example if you want to copy data from the selected 
Rational DOORS module to HP Quality Center, a filter that displays the objects 
you want to copy should be saved with the view.

Note  If you are synchronizing a view that contains Object Text 
requirements that are children of objects that contain Object 
Heading values, then the parent objects are synchronized 
along with their Object Heading values even if your view 
does not contain a mapping to include Object Heading 
values.

HP Quality Center

To set up an HP Quality Center entity for synchronization, select the HP Quality 
Center Domain, Project and Entity along with Attributes you want to make 
available for mapping. If HP Quality Center is to be the controlling application 
for the entity, i.e. if you want to copy data from the entity to Rational DOORS, 
you also select the favorite that displays the elements you want to copy to 
Rational DOORS.
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Synchronization task

The synchronization task defines the rules by which data is transferred between 
the databases. The synchronization task defines the controlling application, 
attribute mappings and a synchronization schedule.

Controlling application

The controlling application is the application that controls the creation and 
deletion of objects. Rational DOORS must be the controlling application for the 
REQUIREMENTS entity, and typically HP Quality Center is the controlling 
application for the TEST and DEFECT entities.

For example, if Rational DOORS is the controlling application for an entity and 
a Rational DOORS user deletes an object that has been synchronized with HP 
Quality Center, the corresponding object is deleted in HP Quality Center the 
next time the synchronization task is run. If an HP Quality Center user deletes 
elements that have been created as the result of a synchronization and the 
corresponding objects still exist in Rational DOORS, those elements are 
recreated when the synchronization task is run.

Note  Only elements and objects that have been created by a 
synchronize are deleted if they are removed from the 
controlling database.

Attribute mappings

Each Rational DOORS attribute that is included in a synchronization task must 
be mapped to a compatible field in HP Quality Center. Data in attributes that are 
not mapped, or that are mapped to incompatible fields, cannot be transferred 
when the synchronization task is run. For information about the attribute and 
field types that are compatible, see “About mapping attributes and fields,” on 
page viii.

When you map attributes, you also define which application is the owner of the 
attribute. The attribute owner is the application that controls the content of the 
individual fields or attributes, and can be either Rational DOORS or HP Quality 
Center. So, although one application controls the creation and deletion of 
objects, you can specify which application can edit the attributes that are 
mapped.

Synchronization

You set a synchronization schedule for each synchronization task. The frequency 
with which a synchronization task should be run will depend on the information 
it contains and how often that information is modified.
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REQUIREMENTS entities and synchronization tasks

The synchronization task is run automatically according to the schedule that is 
set. However, synchronization tasks can also be run manually from Rational 
DOORS, and the administration console.

REQUIREMENTS entities and synchronization tasks

Once you have identified the requirements and attributes that make up the 
qualification criteria for the project, you need to create synchronization tasks to 
copy that information to the REQUIREMENTS entity in HP Quality Center. 
You set up a Rational DOORS module for each subset of data you want to copy 
to HP Quality Center. You must also create one or more HP Quality Center 
entities.

The attributes you included in each Rational DOORS module must be mapped 
to compatible HP Quality Center fields so that the data can be synchronized 
successfully.

The HP Quality Center entities define the Domain, Project, Entity and 
Attributes for the qualification criteria to be copied to. As all of the qualification 
criteria will be copied to the REQUIREMENTS entity, the number of HP 
Quality Center entities you have to create depends on whether all the Rational 
DOORS modules include the same attributes, or different attributes. If they all 
include the same attributes, you can create one HP Quality Center 
REQUIREMENTS entity and map all of the Rational DOORS attributes to it. If 
the Rational DOORS modules contain different attributes, you will have to 
create an HP Quality Center mapping for each Rational DOORS module that 
contains a different set of attributes.

You can create the HP Quality Center fields for mapping manually, or you can let 
the integration do this for you. This function is available when you create the 
synchronization task. Instead of creating and selecting the HP Quality Center 
fields to which you want to map the Rational DOORS attributes, you can create 
it from the Rational DOORS attributes. This will create compatible fields in the 
REQUIREMENTS entity for all the attributes that are included in the Rational 
DOORS module you select, and will include those fields in the HP Quality 
Center mapping that it creates.

Once the HP Quality Center entity has been created, you can select it when you 
create subsequent synchronization tasks, or you can use the function again to 
create new HP Quality Center mappings to other Rational DOORS modules.
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Incremental synchronization of requirements to version-controlled projects

When synchronizing Rational DOORS requirements with an HP Quality Center 
project that is version-controlled, if an incremental synchronization is run, then 
only those Rational DOORS objects that are modified since previous 
synchronization are copied to HP Quality Center. New versions are created for 
these objects in HP Quality Center.

Some Rational DOORS objects might only have modified attributes that are not 
mapped for synchronization. These attributes are referred to as non-mapped 
attributes. For example, in the following figure, the Object Heading attribute in 
Rational DOORS is a mapped attribute. However, all other attributes are 
non-mapped attributes.

In previous releases of this interface, incremental synchronization created new 
versions for Rational DOORS objects even if the objects only contained changes 
to non-mapped attributes. When mail notification was configured, users received 
email notifications for these new versions, even though no HP Quality Center 
attributes had been modified.
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TEST entities and synchronization tasks

The current implementation of incremental synchronization creates new 
versions and email notification only for those Rational DOORS objects in which 
at least one mapped attribute has been modified since previous synchronization. 

This implementation applies only to incremental synchronization and not to full 
synchronization. For full synchronization, new versions are created in HP 
Quality Center for objects with mapped or non-mapped attributes, and for 
objects with no modification since previous synchronization.

TEST entities and synchronization tasks

When tests have been created to verify the qualification criteria in the 
REQUIREMENTS entity and the tests have been associated with the 
requirements they verify, you create synchronization tasks to copy the test data to 
Rational DOORS. You create an HP Quality Center entity for each subset of 
information you want to copy to Rational DOORS. You can copy all of the test 
information to a single Rational DOORS module through one or more 
synchronization tasks, or you can copy subsets of information to different 
modules.

You must also create one or more Rational DOORS modules to which the HP 
Quality Center entities can be mapped.

As with the mappings for the REQUIREMENTS entity, the number of Rational 
DOORS modules you require for mapping is determined by the attributes that 
are included in each HP Quality Center mapping, and whether you want to copy 
the data to one or more Rational DOORS modules. You must create a Rational 
DOORS mapping for each Rational DOORS module you want to copy data to. 
If you want to map more than one HP Quality Center entity to a single Rational 
DOORS module, and the entities contain different attributes for mapping, you 
will have to create views in the Rational DOORS module that displays 
compatible attributes for the fields in each HP Quality Center entity. You must 
then create a Rational DOORS module for each view.

You can create the Rational DOORS modules for mapping manually, or you can 
let the integration do this for you. This function is available when you create the 
synchronization task. Instead of creating and selecting the Rational DOORS 
module to which you want to map the HP Quality Center entity, you can create it 
from the HP Quality Center entity. You select the HP Quality Center entity to 
create the Rational DOORS module from, and the module you want to copy the 
HP Quality Center data to. The integration then creates compatible attributes in 
the module for all the fields that are included in the selected HP Quality Center 
entity, and includes those attributes in the Rational DOORS module it creates.
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Once the Rational DOORS module has been created, you can select it when you 
create subsequent synchronization tasks, or you can use the function again to 
create different Rational DOORS modules for mapping to other HP Quality 
Center entities.

DEFECT entities and synchronization tasks

You create mappings for the DEFECTS entity in the same way as for the TEST 
entity.

Remember that analysts can retrieve information about defects that impact the 
project by creating SoQ attributes in the requirements modules, so it may not be 
necessary to create synchronization tasks for the DEFECTS entity.

Naming synchronization tasks

It is worthwhile spending some time before you start using the integration 
setting up naming conventions for synchronization tasks. This means that it will 
be easier to identify the synchronization tasks and the information that is being 
transferred by them.

You may also want to consider creating a file containing the names and 
descriptions of synchronization tasks, which can be stored in a central location 
and accessed by users of the integration.

About mapping attributes and fields

When you create a synchronization task, you have to map attributes in Rational 
DOORS to fields in HP Quality Center. Data is transferred between the 
attributes and fields that are mapped, so when you map attributes, you must 
make sure that the attribute type in Rational DOORS is compatible with the field 
type in HP Quality Center. The following table shows the types that are 
compatible in Rational DOORS and HP Quality Center.

Rational DOORS attribute type HP Quality Center field type

Date Date

DXL Attribute

Rational DOORS must be the owner.

String

Integer Number
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About mapping attributes and fields

Multi-valued attributes

Rational DOORS must be the owner.

String

Multi-valued attributes are represented in 
HP Quality Center as a comma separated 
list.

Real String

Single-value enumeration

The name of the lookup list to which you 
are mapping the enumeration must be 
added to the enumeration as a value.

Lookup list

The Verify value check box must be 
selected.

You can also map to a string or a memo 
type.

Note When you map a lookup list, make 
sure that the choices in the lookup 
list are equal to, or a subset of, the 
choices available in the single-value 
enumeration.

String

If Rational DOORS is the owner, rich 
text markup and OLE objects are not 
copied to HP Quality Center. The 
attribute may be truncated in HP Quality 
Center.

String or memo

If HP Quality Center is the owner, the 
attribute value is displayed in Rational 
DOORS in plain text.

Rational DOORS attribute type HP Quality Center field type
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The Test name field in the TEST entity in HP Quality Center cannot be empty 
and cannot contain any of the following characters:

• Quotation marks (“ ”)

• Angle brackets (< >)

• Colons (:)

• Commas (,)

• Forward slash (/)

• Back slash (\)

• Question mark (?)

• Bar (|)

• Asterisk (*)

• Percent sign (%)

If you map a Rational DOORS attribute to the Test name field and Rational 
DOORS is the owner of the attribute and the controlling application, you must 

Text

If Rational DOORS is the owner, rich 
text markup and OLE objects are not 
copied to HP Quality Center. The 
attribute may be truncated in HP Quality 
Center.

The Rational DOORS Object text 
attribute cannot be mapped to the HP 
Quality Center string attribute. Object 
text can only be mapped to the HP 
Quality Center memo attribute type.

If Rational DOORS is the owner, OLE 
objects are not copied to the HP Quality 
Center memo attribute type.

String or memo

If HP Quality Center is the owner, the 
attribute value of string type is displayed 
in Rational DOORS in plain text.

Note You may have to increase the 
default size of string fields in HP 
Quality Center from 40 to 255 
characters.

If HP Quality Center is the owner, text 
color in a memo type is not copied to 
Rational DOORS. Attribute values of 
memo type are stored and displayed as 
HTML.

Note HP Quality Center only allows five 
user-defined memo fields in each 
entity. If you want to map more 
than five text attributes, map to 
string field types.

Rational DOORS attribute type HP Quality Center field type
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About mapping attributes and fields

ensure that the Rational DOORS attribute does not contain any of those 
characters.

If Rational DOORS is the controlling application for the TEST entity, tests are 
not synchronized to a folder, and are only visible in grid view.

If you map a Rational DOORS attribute to an entity in HP Quality Center that 
was created during the mapping process, and then synchronize, the new entity is 
not displayed in HP Quality Center until you log out and log back into HP 
Quality Center.

You cannot map the HP Quality Center Target Release and Release Cycle 
fields to Rational DOORS. There are no compatible data types for these fields.
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1 Synchronizing data

• Understanding object synchronization

• Understanding link synchronization

• Synchronizing data from the administration console

• Synchronizing data from Rational DOORS

• Creating traceability columns

Understanding object synchronization

When you run a synchronization task, information is updated according to the 
rules defined in the task. So objects or elements are created and deleted to match 
the controlling application, and attribute values are updated to match the value 
for the owner of each attribute. Information in Rational DOORS tables is not 
included in a synchronization.

Note  Read-only objects in Rational DOORS cannot be updated by 
a synchronization.

For example, if you have a synchronization task where Rational DOORS is the 
controlling application, and the owner of attributes A, B and C and HP Quality 
Center is the owner of attribute D, when you synchronize the task:

• Elements are created in HP Quality Center to match objects that have been 
created in Rational DOORS

• Elements are deleted from HP Quality Center if they were originally created 
in Rational DOORS and the corresponding object in Rational DOORS no 
longer exists

• The values stored in attributes A, B and C are copied from Rational 
DOORS to HP Quality Center

• The values stored in attribute D are copied from HP Quality Center to 
Rational DOORS

Note  If a parent object in the controlling application is deleted and 
the corresponding object in the receiving application has a 
child that is not part of the task you are synchronizing, the 
parent object is not deleted in the receiving application.
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If a synchronization task contains a Rational DOORS column displaying a DXL 
attribute, the data for the attribute will be synchronized to HP Quality Center the 
first time the synchronization task is run. Subsequent synchronizations will not 
update the attribute in HP Quality Center unless the objects have been modified 
in Rational DOORS since the last synchronization. This is because refreshing 
DXL attributes does not change the modified date of an object.

A synchronization schedule is defined for each synchronization task when it is 
created, and the synchronization task is automatically run according to that 
schedule. Tasks can also be synchronized manually from Rational DOORS or 
the administration console.

It is important that an appropriate synchronization schedule is defined, so that 
Analysts and QA/Testers can be confident that they are working with accurate 
and up-to-date information.

Note  If you are going to synchronize large tasks, the HP Quality 
Center client timeout setting should be set to either a high 
value or -1 value. If a small value is used, the HP Quality 
Center client being used for the synchronization could 
timeout before it is finished.

Note  During synchronization, you can work in a Rational DOORS 
module that is open in exclusive edit mode; however, some 
limitations might apply. For more information, see the 
technote “Rational DOORS HP Quality Center Interface 
synchronization fails if the Rational DOORS module is open 
in exclusive edit mode in some scenarios” at 
http://www.ibm.com/support/docview.wss?uid=swg21692
635.

Understanding link synchronization

When you run a TEST synchronization task, links from tests to requirements 
that are included in the synchronization task are also synchronized. This means 
that links between objects in Rational DOORS are replicated between the 
corresponding elements in HP Quality Center when a synchronization task that 
includes the source objects is run. Similarly, associations between elements in HP 
Quality Center are replicated between the corresponding objects in Rational 
DOORS when a synchronization task that includes the source elements is run.

Links are not copied during a synchronization if they:

• Go in the opposite direction than specified above, for example links from 
requirements to tests.

http://www.ibm.com/support/docview.wss?uid=swg21692635
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Synchronizing data from the administration console

• Are between objects or elements in the same task, for example links between 
requirements in a task.

• Are between objects or elements other than those specified above, for 
example links between tests and test sets.

Which application controls the creation and deletion of links?

There is no controlling application for the creation and deletion of links. As long 
as a link conforms to the rules for link synchronization it will be synchronized 
when the synchronization task is run:

• If a link or association is created in one database and the corresponding 
objects exist in the other database, the link will be created when the 
synchronization task is run.

• If a link or association that has been created as a result of a previous 
synchronization is deleted in either database, the corresponding link will be 
deleted when the synchronization task is run.

• If a synchronized link is independently deleted in both databases, and a new 
link is created in one database, that link will be deleted by a synchronization.

What happens when a linked object is deleted?

If an object that has a synchronized link is deleted from the database of the 
controlling application for the entity, running the synchronization task has the 
following effect:

• The corresponding object in the other database is deleted.

• The previously synchronized link is deleted.

If an object that has a synchronized link is deleted from the database that is not 
the controlling application for the entity, the link is also deleted. However, 
because a synchronization recreates the object, this indirect link deletion is 
invalid, so the corresponding link in the controlling application is not deleted. 
When the synchronization task is run, the object that was deleted is recreated 
along with the link.

Synchronizing data from the administration console

The administration console is the recommended application to use when you 
want to synchronize data. Only use Rational DOORS to synchronize when you 
do not have access to the administration console.

For information about how to synchronize data using the administration console 
see the console’s online help.
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Note  In some cases, after upgrading Rational DOORS, if you 
attempt to validate synchronization tasks in the 
administration console, the Rational DOORS client opens 
for each task. If you do not log in each time, the validation 
fails. To resolve this problem, run the Set Access Permissions 
wizard. Then select the Modify option in the administration 
console and test the connection to the Rational DOORS 
data.

Synchronizing data from Rational DOORS

In a Rational DOORS module, you can run a single synchronization task, or all 
of the synchronization tasks that are associated with the module.

Note  Once the synchronization has been started, it cannot be 
cancelled. Clicking the Cancel button at any stage does not 
stop the synchronization.

To run a single synchronization task:

1. In the Rational DOORS module window, click DOORSConnect > 
Quality Center > Synchronize > Synchronize Task.

A dialog box containing a list of all the synchronization tasks associated with 
the current module is displayed.

2. Select the synchronization task, and click Sync.

A Link Synchronization dialog box is displayed.

3. Click Objects and Links or Objects only.

A message stating that the module’s edit mode is being changed to read only 
is displayed.

4. Click OK.

Objects and optionally links in Rational DOORS and HP Quality Center are 
synchronized according to the synchronization task mapping information.

When the synchronization is complete, a report is generated. This contains 
details of:

• Objects and elements that have been created
• Objects and elements that have been deleted
• Objects and elements that have been modified
• Links that have been created
• Links that have been deleted
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• Any errors or warnings that were generated

5. Change back to exclusive edit mode to see any updates that have been made 
by the synchronization.

To run all synchronization tasks:

1. In the Rational DOORS module window, click DOORSConnect > 
Quality Center > Synchronize > Synchronize All Tasks.

A confirmation dialog box is displayed.

2. Click Confirm to run all the synchronization tasks associated with the 
module.

A Link Synchronization dialog box is displayed.

3. Click Objects and Links or Objects only.

A message stating that the module’s edit mode is being changed to read only 
is displayed.

4. Click OK.

Objects and optionally links in Rational DOORS and HP Quality Center are 
synchronized according to the synchronization task mapping information.

When the synchronization is complete, a report is generated. This contains 
details of:

• Objects and elements that have been created
• Objects and elements that have been deleted
• Objects and elements that have been modified
• Links that have been created
• Links that have been deleted
• Any errors or warnings that were generated

5. Change back to exclusive edit mode to see any updates that have been made 
by the synchronization.

Creating traceability columns

You can create traceability columns that display information about links that 
have been synchronized as part of a synchronization task. Only links that satisfy 
the criteria for link synchronization can be analyzed in a traceability column. For 
more information see “Understanding link synchronization,” on page ii.

To create traceability columns:
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1. In the Rational DOORS module window, click DOORSConnect > 
Quality Center > Create Traceability Column.

This runs the Task Traceability Analysis wizard.

2. Click Next on the Welcome screen.

3. Select the tasks and the direction of the links you want to analyze.

4. Click Next.

5. Select the attributes you want to display in the traceability column for each 
selected task.

Click Next and repeat this step for each task selected in the previous step.

6. On the Recursion Depth screen, type the number of traceability columns 
you want to display.

7. Click Next.

8. Click Finish.

The traceability columns are added to your view.
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1 Creating SoQ Attributes

• Understanding SoQ Attributes

• Creating the SoQ Value Attribute

• Creating the SoQ Defect Attribute

• Creating the SoQ Report Attribute

Understanding SoQ Attributes

Statement of Quality (SoQ) attributes provide three levels of reporting against 
qualification criteria that have been integrated with HP Quality Center through 
requirement and test tasks:

• SoQ Value

• SoQ Defect

• SoQ Report

They enable the analyst to see varying degrees of detail about the test status of 
the project at milestones in the project.

SoQ value attributes cannot be calculated unless the requirements and tests that 
verify them have been included in synchronization tasks, and those 
synchronization tasks have been run at least once. SoQ attributes will only 
display results for the tests that are associated with the requirements in the 
synchronization task.

You create the SoQ Value attribute in the Rational DOORS Requirements 
module.

Note  The Qualification Attribute menu options are only displayed 
in modules that are mapped to the REQUIREMENTS entity 
in HP Quality Center through a synchronization task.

Understanding the SoQ Value attribute

The SoQ Value attribute provides information about the status of the tests in HP 
Quality Center that are associated with requirements, and that are included in 
synchronization tasks that have been run by the integration. Each Rational 
DOORS requirement is checked for associated TESTS in HP Quality Center, 
and where associated tests are found, it displays results from the latest run of the 
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test set you select. For each requirement one of the following values will be 
displayed in the SoQ Value attribute:

SoQ Value of... Means...

No coverage There are no TEST elements associated with the Rational 
DOORS requirements.

Failed There is at least one TEST element associated with the 
Rational DOORS requirement that has been run and has a 
verdict of Failed.

Not-run Each TEST element associated with the Rational DOORS 
requirement has a verdict of either Not-run, Passed or N/A.

Not-completed At least one TEST element associated with the Rational 
DOORS requirement has a verdict of Not-completed.

N/A All TEST elements associated with the Rational DOORS 
requirement have a verdict of N/A.

Qualified All of the TEST elements associated with the Rational 
DOORS requirement have been run and have a verdict of 
Passed or N/A.

SoQ values are propagated up through the requirements hierarchy. So if a 
Rational DOORS object has children, the SoQ value of the child object is 
considered when the SoQ value of the parent is calculated. For example, if the 
SoQ value of a child object is Not-completed, the SoQ value that is reported to 
the analyst for the parent object is Not-completed. The analyst can navigate 
through the hierarchy to see which child object has the value Not-completed, 
and can determine the business impact of that result.

If any descendant of an object has an SoQ value of No coverage, the parent 
object will also have an SoQ value of No Coverage. If that object also has a 
descendant with an SoQ value of Failed, the SoQ value of the parent will be 
Failed, not No Coverage.

Understanding the SoQ Defect attribute

The SoQ Defects attribute displays the same information as the SoQ Value 
attribute for all attribute values except Failed. Where an SoQ Value is Failed, 
the integration will retrieve and display defects that have been raised against, or 
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associated with, tests that are associated with the Rational DOORS requirement 
and that have failed in the latest run of the test set you selected.

There are several ways to create associations between defects and runs in HP 
Quality Center. Defects that are associated in the ways described below are 
displayed when the SOQ Defect attribute is calculated.

Using HP Quality Center functionality, you can create an association between a 
defect and a run in one of two ways:

• When you run a test, and it fails, you raise a defect. HP Quality Center 
records the RUN in the DEFECT. As the defect is associated with a 
particular run, it cannot be associated with any other test. So, if a single 
defect is the reason why two different tests have failed, you have to raise two 
identical defects, one for each failed run. When you calculate the SoQ defect 
attribute, all of the defects that are associated with failed runs are displayed.

• Alternatively, some HP Quality Center users work around this limitation by 
customizing HP Quality Center. They create an attribute in the RUN entity, 
and use this customization to record the defect ID of the defect that has 
caused the test to fail. This means that one defect can be associated with 
numerous runs. If this is the way that you associate defects with runs in HP 
Quality Center, you must provide the name of the attribute that you use to 
record the defect ID when you create the SoQ Defect attribute, or those 
defects will not be displayed when the SoQ Defect attribute is calculated. 
You do this by selecting the attribute name from the Attribute as Defect 
ID list on the SoQ Defect dialog box.

Understanding the SoQ Report

The SoQ Report displays the same information as the SoQ Defects attribute, 
along with a summary of how elements of type TEST are associated with the 
Rational DOORS requirement, and gives the verdicts from the SoQ Value that 
have resulted in the value that is reported.

Creating the SoQ Value Attribute

1. In the Rational DOORS module window, click DOORSConnect > 
Quality Center> Qualification Attribute > SoQ Value.

Note  You need modify access to the module.

2. Type a name in Attribute Name.

The prefix SoQValue_ is automatically added to the name. For example, if 
you enter Attribute, the attribute will be named SoQValue_Attribute.
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3. Select the synchronization task that defines the requirements for which you 
want to calculate SoQ attributes from the Task drop-down list.

4. Select a Test Set from the Test set drop-down list.

5. Click Calculate.

If the module is open in either read-only or shareable edit mode, it will be 
changed to exclusive edit mode before starting the calculation.

Creating the SoQ Defect Attribute

1. In the Rational DOORS module window, click DOORSConnect > 
Quality Center > Qualification Attribute > SoQ Defects.

Note  You need modify access to the module.

2. Enter a name in Attribute Name.

The prefix SoQDefect_ is automatically added to the name. For example, if 
you enter Attribute, the attribute will be named SoQDefect_Attribute.

3. Select the synchronization task that defines the requirements for which you 
want to calculate SoQ attributes from the Task drop-down list.

4. Select a Test Set from the Test set drop-down list.

5. The Attribute as Defect Id list is populated with attributes from the RUN 
entity in HP Quality Center. If you have created an attribute in the RUN 
entity where you can enter the Defect ID of any associated defect manually, 
select that attribute from the list. Those defects will also be included in the 
SoQ Defect attribute. For more information about this option, see 
“Understanding the SoQ Defect attribute,” on page ii.

6. Select attributes to display in the SoQ Defect attribute from the Defect 
Attributes list.

• To save the attribute configuration for use later, click Save. Browse to 
the folder, and click Save.

• To load a configuration that you have saved previously, click Load. 
Browse to the folder that contains the configuration file, and click Load.

7. Click Calculate.

The SoQ defect value for each object in the task is calculated.



Using Rational DOORS for HP Quality Center Interface           v

Creating the SoQ Report Attribute

Creating the SoQ Report Attribute

1. In the Rational DOORS module window, click DOORSConnect > 
Quality Center > Qualification Attribute > SoQ Report.

Note  You need modify access to the module.

2. Follow the instructions in “Creating the SoQ Defect Attribute,” on page iv, 
Step 2 to Step 6.

3. Click Calculate.

The SoQ report value for each object in the task is calculated and displayed in 
table format. The table summarizes how elements of type TEST are associated 
with the Rational DOORS object.
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1 Getting started with the administration 
console

What do you want to learn about?

• About the administration console

What do you want to do?

• Log in to the administration console

• Connect to an integration server

About the administration console

You use the administration console to define attribute mappings and the 
synchronization tasks that exchange data between Rational DOORS and HP 
Quality Center. A synchronization task is a set of mappings between attributes in 
Rational DOORS and fields in HP Quality Center.

The synchronization tasks are set up using common attribute maps, and can be 
scheduled to run at predetermined times or on demand.

The administration console provides you with an easy way to set up the 
synchronization tasks, the attribute mappings for each task, and to schedule 
when each task will be run.

Users who install the administration console will be able to create attribute maps, 
create synchronization tasks, and create new attributes in Rational DOORS and 
entities in HP Quality Center. If you only want to run synchronizations, you can 
install the Rational DOORS client and synchronize from Rational DOORS.

For information about synchronization tasks, see About synchronization tasks 
and for information about improving the performance of the synchronization 
tasks, see Improving performance of synchronization tasks.

Log in to the administration console

To log in to the administration console:

1. Start the administration console.

From the Start menu, click IBM Rational > IBM Rational Tools > IBM 
Rational DOORS Quality Center Interface 3.5 Tools > Administration 
Tool.
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Note  To run the administration console, you must be a 
database manager or a custom user with manage 
database powers. You must also be a member of the 
group that has permission to access the 
administration console.

2. Select an integration server from the Server list.

3. Click OK if you use Integrated Windows Authentication, or clear the check 
box and type in your user name and password, and then click OK.

Connect to an integration server

To connect to an integration server:

1. Click Tools > Connection Manager.

The Server Connection Manager dialog box is displayed.

2. Enter the address, name and description of the integration server.

You can specify as many integration servers as you want.

3. If you have specified more than one integration server, select a default .

4. Click OK.
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1 Data Connections

What do you want to do?

• Create a connection to Rational DOORS

• Create a connection to HP Quality Center

• Delete a connection

Create a connection to Rational DOORS

To create a connection to Rational DOORS:

1. Click File > New > Data Connection.

The New Data Connection wizard is displayed.

2. Select Rational DOORS, and click Next.

3. Specify the server and user details for the Rational DOORS connection:

a. Enter the location of the server, in the following format:

port@servername

Replace port with the port number you are using, and servername 
with the name of the server.

b. Enter your user name and password.

c. Select Test Connection to make sure the user name, password, and 
location are correct.

d. Click Next.

4. If you want, set up a time during which synchronizations cannot be run.

This time is set per database.

a. Select Enable Exclusion Time Window.

b. Enter a start time and an end time. This is the time during which 
synchronizations cannot be run.

c. Click Next.

Summary information is displayed in the Data Connection Summary 
screen.

5. Click Finish.
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Create a connection to HP Quality Center

To create a connection to HP Quality Center:

1. Click File > New > Data Connection.

The New Data Connection wizard is displayed.

2. Select HP Quality Center, and click Next.

3. Specify the server and user details for the HP Quality Center connection:

a. Enter the location of the server, in the following format:

http://servername:port/qcbin

Replace servername with the name of the server, and port with the 
port number.

b. Enter the user name and password.

c. Select Test Connection to make sure the user name, password, and 
location are correct.

d. Click Next.

4. Enter the number of sessions and number of objects for the connection, and 
click Next.

These settings set the maximum number of chunks that can be run in 
parallel, and the maximum number of objects in each chunk.

5. If you want, set up a time during which synchronizations cannot be run:

a. Select Enable Exclusion Time Window.

b. Enter a start time and an end time. This is the time during which 
synchronizations cannot be run.

c. Click Next.

Summary information is displayed in the Data Connection Summary 
screen.

6. Click Finish.

Delete a connection

To delete a connection:

1. Click Tools > Data Provider Manager.

2. Select the connection, and right-click Delete.
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1 Common attribute maps and data end 
points

What do you want to learn about?

• About common attribute maps

• About data end points

• About mapping attributes and fields

What do you want to do with attribute maps?

• Create an attribute map

• Change the name and description of an attribute map

• Delete an attribute map

• Clear all connections

What do you want to do with data end points?

• Add data end points

• Map end points

• Clear all connections

About common attribute maps

Once you’ve set up the connections between your Rational DOORS databases 
and HP Quality Center databases, you need to set up attribute maps.

Synchronizations between Rational DOORS and HP Quality Center are based 
on attribute maps. Attribute maps are the relationships between Rational 
DOORS attribute types and HP Quality Center field types.

Data is transferred between the attributes and fields that are mapped. When you 
map attributes, you must make sure that the attribute type in Rational DOORS is 
compatible with the field type in HP Quality Center. For example, you might set 
up a relationship between a string attribute type in Rational DOORS and a string 
field type in HP Quality Center. This mapping would allow the data to be shared 
between the two.

When you begin to plan the mappings between different modules in Rational 
DOORS and HP Quality Center, you quickly realize that many of the mappings 
are similar. For example, the attribute types in a Rational DOORS module that 
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map to the field types in an HP Quality Center entity are similar, if not the same, 
as those between other modules and entities.

To take advantage of this fact, Rational DOORS for HP Quality Center Interface 
uses common attribute maps to allow you to set up the relationships between 
Rational DOORS and HP Quality Center quickly and easily.

When you set up your common attribute maps, they are used to organize your 
synchronization tasks. For example, if you have four synchronization tasks that 
use the same common attribute map, they are displayed under it (almost as if the 
common attribute map were a folder):

For more information about synchronization tasks, see Synchronization tasks.

About data end points

Part of the process of creating attribute maps involves setting up connections 
between modules in Rational DOORS and test entities in HP Quality Center. 
These modules and test entities are called the master end point and the target 
end point, known collectively as data end points.

The master end point is the application that controls the creation and deletion of 
objects. Rational DOORS must be the master end point for the 
REQUIREMENTS entity, and typically HP Quality Center is the master end 
point for the TEST and DEFECT entities.

For example, if Rational DOORS is the master end point for an entity and a 
Rational DOORS user deletes an object that has been synchronized with HP 
Quality Center, the corresponding object is deleted in HP Quality Center the 
next time the synchronization task is run. If an HP Quality Center user deletes 
elements that have been created as the result of a synchronization, and the 
corresponding objects still exist in Rational DOORS, those elements are 
recreated when the synchronization task is run.

Note  Only elements and objects that have been created by a 
synchronize are deleted if they are removed from the master 
database.
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Once you have set up the data end points and set up a relationship between the 
Rational DOORS module and the HP Quality Center test entity, you can then 
map each object in the Rational DOORS module to an object in the HP Quality 
Center test entity.

Create an attribute map

Creating an attribute map is a two-step process. First you create a map using data 
end points, and then you map the attributes in Rational DOORS to fields in HP 
Quality Center.

To create an attribute map:

1. Click File > New Attribute Map.

The New Attribute Map wizard is displayed.

2. Enter the map name and description.

3. Click Next.

4. Enter a master end point and target end point.

5. Click Finish.
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The new attribute map is added to the hierarchy, the end points are displayed in 
the Data Providers pane, and the attributes in the end points are displayed in 
the New Attribute Mapping Designer pane.

You now need to map the attributes in Rational DOORS to fields in HP Quality 
Center. For information about mapping attributes and fields, see About mapping 
attributes and fields.

If you know about mapping attributes and fields, continue the procedure.

6. Using the buttons in the administration console taskbar, set the interface to 
your own preference:

Button Button name Description

Show/Hide Data 
Providers

Shows or hides the Data Providers pane.

Show/Hide Linked 
Attributes

Shows or hides the attributes that have 
already been mapped. At this stage in the 
procedure, none of the attributes are 
mapped.
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7. Select the attribute or field and drag it to the attribute or field you want to 
map it to.

Each attribute or field can have only one mapping.

When you select a field or attribute, and start to drag it, the destination data 
end point only displays the fields or attributes that you can drag it to. For 
example, if you select a string field and drag it towards the Rational DOORS 
data end point, only attributes of the type string or text that are not already 
mapped are displayed.

If necessary, you can create attributes from scratch, or select an attribute and 
create a counterpart attribute to map it to. See either Create attributes or 
Create counterpart attributes.

8. If you are mapping a multi-value enumeration, the Enumeration Value 
Mapping Dialog box is displayed. For each Source value, select a Target 
value from the drop-down list, and click OK.

9. When you have completed the mappings, click Validate  to make sure 
that the mappings are valid.

10. Click Save Mapping .

Create attributes

You can create attributes.

To create attributes:

1. Select the attribute map, and click Mappings > Data end point > Create 
Attributes.

The Create Attributes wizard is displayed.

2. Enter the attribute name, select the attribute type from the list, and then 
click Next.

3. If you want to create another attribute, click Next, and repeat step 2.

4. When you have created all the attributes, click Finish.

Show/Hide 
Descriptions

Shows or hides the text describing the 
panes.

Button Button name Description
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Create counterpart attributes

Counterpart attributes allow you to create a corresponding attribute in the target 
system.

To create counterpart attributes:

1. Select the attribute that you want to create a counterpart for.

2. Right-click Create Counterpart.

The Create Attributes wizard is displayed.

3. Select an attribute type.

You can select an attribute type based on the source type or on an existing 
compatible type.

4. Click Next.

5. Enter a new attribute name and click Next.

The attribute is created.

6. Click Finish.

Change the master end point

Each attribute map has a master end point and a target end point. You can 
change them so that the target becomes the master, and the master becomes the 
target.

To change the master end point:

1. Select the container of the target end point in the Mapping screen.

2. Right-click Set as Master.

3. Click Save Mapping .

The target is set as the master.

When you change the end points, verify that the mappings in the tasks in the 
attribute map are still valid.

Replace an end point 

Each attribute map has a master end point and a target end point. You can 
replace an end point.

To replace an end point:

1. Select the container of the end point in the Mapping screen.

2. Right-click Clear Container.
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The end point is removed.

3. Select a new end point from the Data Providers pane, and drag it to the 
empty container.

4. Set one of the end points as the master. Select the container, and right-click 
Set as Master.

5. Map the attributes and fields.

6. When you have completed the mappings, click Validate  to make sure 
that the mappings are valid.

7. Click Save Mapping .

When you change the end points, verify that the mappings in the tasks in the 
attribute map are still valid.

Change the name and description of an attribute map

You can change the name and description of an attribute map.

To change the name and description an attribute map:

1. Select the attribute map, and right-click Edit Name and Description.

The Edit Integration Map Name and Description window is displayed.

2. Enter the new details, and click OK.

Delete an attribute map

When you delete an attribute map, all the synchronization tasks that are 
contained in it are also deleted.

To delete an attribute map:

1. Select the attribute map, and click Edit > Delete Attribute Map.

2. Click Yes.

Clear all connections

You can clear all the mappings between attributes and fields.

To clear all connections:

• Click Mappings > Clear Connections, and click Yes.
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About mapping attributes and fields

You need to map attributes in Rational DOORS to fields in HP Quality Center. 
Data is transferred between the attributes and fields that are mapped, so when 
you map attributes, you must make sure that the attribute type in Rational 
DOORS is compatible with the field type in HP Quality Center. The following 
table shows the types that are compatible in Rational DOORS and HP Quality 
Center.

Rational DOORS attribute type HP Quality Center field type

Date Date

DXL Attribute

Rational DOORS must be the owner.

String

Integer Number

Multi-value enumeration

Part of the mapping process is to map 
each of the individual values in the 
source application to a value in the target 
application.

Lookup list

Real String

Single-value enumeration

The name of the lookup list to which you 
are mapping the enumeration must be 
added to the enumeration as a value.

Lookup list

The Verify value check box must be 
selected.

You can also map to a string or a memo 
type.

Note When you map a lookup list, make 
sure that the choices in the lookup 
list are equal to, or a subset of, the 
choices available in the single-value 
enumeration.
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About mapping attributes and fields

The Test name field in the TEST entity in HP Quality Center cannot be empty, 
and cannot contain any of the following characters:

• Quotation marks (“ ”)

• Angle brackets (< >)

• Colons (:)

• Commas (,)

• Forward slash (/)

• Back slash (\)

• Question mark (?)

String

If Rational DOORS is the owner, rich 
text markup and OLE objects are not 
copied to HP Quality Center. The 
attribute may be truncated in HP Quality 
Center.

String or memo

If HP Quality Center is the owner, the 
attribute value is displayed in Rational 
DOORS in plain text.

Text

If Rational DOORS is the owner, rich 
text markup and OLE objects are not 
copied to HP Quality Center. The 
attribute may be truncated in HP Quality 
Center.

The Rational DOORS Object text 
attribute cannot be mapped to the HP 
Quality Center string attribute. Object 
text can only be mapped to the HP 
Quality Center memo attribute type.

If Rational DOORS is the owner, OLE 
objects are not copied to the HP Quality 
Center memo attribute type.

String or memo

If HP Quality Center is the owner, the 
attribute value of string type is displayed 
in Rational DOORS in plain text.

Note You may have to increase the 
default size of string fields in HP 
Quality Center from 40 to 255 
characters.

If HP Quality Center is the owner, text 
color in a memo type is not copied to 
Rational DOORS. Attribute values of 
memo type are stored and displayed as 
HTML.

Note HP Quality Center only allows five 
user-defined memo fields in each 
entity. If you want to map more 
than five text attributes, map to 
string field types.

Rational DOORS attribute type HP Quality Center field type
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• Bar (|)

• Asterisk (*)

• Percent sign (%)

If you map a Rational DOORS attribute to the Test name field, and Rational 
DOORS is the owner of the attribute and the controlling application, you must 
ensure that the Rational DOORS attribute does not contain any of those 
characters.

If Rational DOORS is the controlling application for the TEST entity, tests are 
not synchronized to a folder, and are only visible in grid view.

You cannot map the HP Quality Center Target Release and Release Cycle 
fields to Rational DOORS. There are no compatible data types for these fields.

If you map a Rational DOORS attribute to an entity in HP Quality Center that 
was created during the mapping process, and then synchronize, the new entity is 
not displayed in HP Quality Center until you log out and log back in to HP 
Quality Center.

You can only have one set of mappings for a task.

Add data end points

To add a data end point:

1. Click Tools > Data Provider Manager, select the server that contains the 
data you want to add as a data end point, and then right-click Add End 
Point.

You can select either a Rational DOORS server or an HP Quality Center 
server.

The Create End Point window is displayed.

2. Browse to the data end point you want to add, and either enter a display 
name or click Use End Point Path.

3. Click OK.

The data end point is added.

Map end points

When you have created the data end points, you need set up relationships 
between Rational DOORS data end points and HP Quality Center end points by 
dragging and dropping.
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Map end points

To set up a relationship between end points:

1. Click on either a Rational DOORS end point, or an HP Quality Center end 
point, and drag it to one of the drop zones.

2. Click on the other data end point, and drag it to the other drop zone.

3. Make one of the end points the master end point.

Right-click the end point and click Set as Master.

4. Click Validate  to make sure the relationship is valid.

The relationship between the end points is set up. Each end point is expanded, 
and the attributes within the Rational DOORS data end point and the fields 
within the HP Quality Center data end point are displayed.
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1 Synchronization tasks 

What do you want to learn about?

• About synchronization tasks

• Improving performance of synchronization tasks

What do you want to do with synchronization tasks?

• Set synchronization tasks to run in parallel

• Create a synchronization task

• Edit a synchronization task

• Move a synchronization task

• Delete a synchronization task

About synchronization tasks

When you run a synchronization task, information is updated according to the 
rules defined in the task. Objects or elements are created and deleted to match 
the controlling application, and attribute values are updated to match the value 
for the owner of each attribute. Information in Rational DOORS tables is not 
included in a synchronization.

Note  Read-only objects or elements cannot be updated by a 
synchronization.

For example, if you have a mapping where Rational DOORS is the controlling 
application, and the owner of attributes A, B, and C and HP Quality Center is the 
owner of attribute D, when you synchronize:

• Elements are created in HP Quality Center to match objects that have been 
created in Rational DOORS.

• Elements are deleted from HP Quality Center if they were originally created 
in Rational DOORS and the corresponding object in Rational DOORS no 
longer exists.

• The values stored in attributes A, B, and C are copied from Rational 
DOORS to HP Quality Center.

• The values stored in attribute D are copied from HP Quality Center to 
Rational DOORS.
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Note  If a parent object in the controlling application is deleted and 
the corresponding object in the receiving application has a 
child that is not part of the synchronization, the parent object 
is not deleted in the receiving application.

If a task contains a Rational DOORS column displaying a DXL attribute, the 
data for the attribute will be synchronized to HP Quality Center the first time the 
synchronization is done. Subsequent synchronizations will not update the 
attribute in HP Quality Center unless the objects have been modified in Rational 
DOORS since the last synchronization. This is because refreshing DXL 
attributes does not change the modified date of an object.

A schedule is defined for each synchronization task when it is created, and the 
synchronization task is automatically run according to that schedule. You can 
also run synchronization tasks manually from the administration console.

It is important that an appropriate schedule is defined, so that Analysts and 
QA/Testers can be confident that they are working with accurate and up-to-date 
information.

Note  If you are going to run large synchronization tasks, the HP 
Quality Center client time-out setting should be set to either 
a high value or -1 value. If a small value is used, the HP 
Quality Center client being used for the synchronization 
might time out before it is finished.

Improving performance of synchronization tasks

Rational DOORS for HP Quality Center Interface gives you a number of 
different ways to improve the performance of synchronization tasks. You can set 
up your system so that it performs the following tasks:

• Running synchronization tasks in chunks

• Running synchronization tasks in parallel

• Running synchronization tasks in parts

• Running synchronization tasks at specific times

Running synchronization tasks in chunks

If you have a synchronization task that contains a large number of objects to be 
processed, you can break it down into “chunks”, and run each chunk in parallel. 
There are settings that allow you to determine the maximum number of chunks 
that can run in parallel and the maximum number of objects in each chunk. For 
example, if you have a synchronization task that processes 5,000 objects, you can 
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Improving performance of synchronization tasks

set your system to run a maximum of five chunks in parallel, with each chunk 
containing a maximum of 1,024 objects. When the synchronization task is run, 
five separate processes of 1,024 objects are run in parallel. Instead of carrying 
out 5,000 processes one after the other, your system can carry out the 5,000 
processes in a much shorter time.

Running synchronization tasks in parallel

As well as being able to break down synchronization tasks into different chunks 
that can then be run in parallel, you can also set up your system to run the 
synchronization tasks themselves in parallel. The number of synchronization 
tasks that you can run simultaneously is determined only by your hardware.

You can also prioritize your tasks, making sure that the most important tasks are 
always run first.

Running synchronization tasks in parts

As well as being able to break down synchronization tasks into chunks and then 
running the synchronization tasks themselves in parallel, you can also select to 
run only parts of a synchronization task.

Each task is now broken down into three separate parts:

• Content

The content part of the synchronization task refers to changes to the data 
that need to be synchronized, for example straightforward changes to the 
text in a requirement.

• Structure

The structure part of the synchronization task refers to changes to the 
hierarchy of the objects in the task, for example when objects are created, 
moved, or deleted.

• Links

The links part of the synchronization task refers to changes to the links in 
and out of the objects in the task.

For example, if you know that a synchronization task very rarely contains 
changes to the structure or to links, you can split it into two tasks: one task that 
processes only changes to the content, and a separate task that processes the 
changes to the content, the structure, and the links. You can then run the first 
task every night, and run the second task every week.
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Running synchronization tasks at specific times

Finally, there is a setting that allows you to set up a specific time during which a 
synchronization task is run. By entering a start time and end time, you can make 
sure tasks are not run when you need to have access to your databases to carry 
out other tasks. Typically, synchronization tasks are run overnight; you can use 
the start time and end time to make overnight runs the only time when 
synchronization tasks can be run.

This time is set per database.

Note: Elements are created during a synchronization task, where Rational 
DOORS is configured to run as master and HP Quality Center is run as slave. If 
you log in to HP Quality Center client and delete the elements that are created in 
the synchronization task and re-run the synchronization again, the metadata  files 
get corrupted in HP Quality Center client.

Set synchronization tasks to run in parallel

By default, the system is set up to run your synchronization tasks one at a time. If 
you want your system to run synchronization tasks in parallel, you must run the 
Global Synchronization Options wizard.

To set synchronization tasks to run in parallel:

1. Click Tools > Options.

The Global Synchronization Options wizard is displayed.

2. Click Enable parallel synchronization tasks.

3. Click Finish.

Create a synchronization task

To create a synchronization task:

1. Select the attribute map where you want to create the new task, and click 
File > New > Synchronize Task.

The New Synchronization Task wizard is displayed.

2. Enter the task name and description, and click Next.

3. Enter a master end point and a target end point, and click Finish.

You are now ready to schedule and configure the task. For more information, see 
Scheduling and configuring synchronization tasks.



Using Rational DOORS for HP Quality Center Interface           v

Edit a synchronization task

Edit a synchronization task

You can change the name and description of a synchronization task.

To edit a synchronization task:

1. Select the synchronization task, and click Edit > Edit Name and 
Description.

The Edit Synchronization Task Name and Description window is 
displayed.

2. Enter a new name and description, and click OK.

Move a synchronization task

You can move a synchronization task from one attribute map to another. 
However, before you move the task, verify that the new attribute map is 
appropriate for the task. For example, do not move a task if the attribute map 
you are moving from has Rational DOORS as the master end point and the 
attribute map you are moving to has an HP Quality Center master end point.

To move a synchronization task:

1. Select the synchronization task, and click Edit > Move To Attribute Map.

The Move to window is displayed.

2. Select the attribute map you want to move the synchronization task to, and 
click Move.

The Task Summary screen is displayed.

Verify that the new attribute map is appropriate for the synchronization task: 

• Click Save Endpoints to make sure the end points are valid.
• Click Validate Mapping to make sure the new mapping is valid.

Delete a synchronization task

To delete a synchronization task:

1. Select the synchronization task, and click Edit > Delete.

2. Click Yes.
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1 Scheduling and configuring 
synchronization tasks

What do you want to learn about?

• About scheduling synchronization tasks

• About configuring synchronization tasks

What do you want to do?

• Schedule synchronization tasks

• Configure synchronization tasks

• Run a manual synchronization task

• Disable a synchronization task

• Enable a synchronization task

About scheduling synchronization tasks

A synchronization task can occur once (on demand) or repeatedly (a recurring 
task). A recurring synchronization task is repeated at regular intervals, just like an 
appointment you set up in a calendar application. For example, you can schedule 
a synchronization task to run every day or every Monday at a specific time. You 
can also assign a priority to the task.

You can schedule a synchronization task to run only once every 24 hours. If you 
change the scheduled time of a synchronization task from 1:00 P.M. to 3:00 P.M., 
the task will not run again until 3:00 P.M the next day. 

However, you do not need to wait until a synchronization task is scheduled 
before it can be run. You can run a manual synchronization task at any time.

Schedule synchronization tasks

To schedule a synchronization task:

1. Select the Scheduling tab.

The Scheduling screen is displayed.

2. Enter the time you want the task to start.

3. Assign a priority to the task. Enter 1 for the highest priority and 5 for the 
lowest.
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4. To make the task recurring, select Recurring Task, and choose the 
Recurrence Options and the Recurrence Range.

Note  If you intend to run the task more than once, set the task 
to recur. If you set the task to run once, and then 
subsequently try to run the task again by changing the 
scheduled time, the task will not run.

5. Click Save the Schedule .

About configuring synchronization tasks

As well as being able to schedule synchronization tasks, you can also select to run 
only parts of a synchronization task.

Each task can be broken down into three separate parts:

• Content: refers to changes to the data that need to be synchronized, for 
example straightforward changes to the text in a requirement.

• Structure: refers to changes to the hierarchy of the objects in the task, for 
example when objects are created, moved, or deleted.

• Links: refers to changes to the links in and out of the objects in the task.

You can also enter the number of threads to use for the task. 

The number of threads is determined by the size of the task, and the hardware 
you are running. If you are running a large task, and you have the computing 
capacity, increase the number of threads.

Configure synchronization tasks

To configure a synchronization task:

1. Select the Configuration tab.

The Configuration screen is displayed.

2. Select the parts of the task that you want to run.

3. Enter the number of threads to use for the synchronization task, and click 
Save Configuration .

Run a manual synchronization task

You do not need to wait until a synchronization task is scheduled before it can be 
run. You can run a manual synchronization task at any time.
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Run a manual synchronization task

You can choose to run either an incremental synchronization or a full 
synchronization:

• Running an incremental synchronization is essentially the same as running 
the scheduled synchronization. The synchronization only makes the changes 
that it has been configured to make. If the synchronization is configured to 
run all three parts - content, structure, and links - then all three parts are 
synchronized. Under usual circumstances, you will run this type of manual 
synchronization.

• Running a full synchronization is essentially the same as resending all the 
information from the master to the target. If you are working with a large 
module, this type of synchronization can take a long time to complete. 
Under usual circumstances, you will rarely run this type of manual 
synchronization.

To run an incremental synchronization:

1. Select the task, and click File > Execute Now > Incremental 
Synchronization.

A Progress window is displayed with details of the synchronization.

You can view a report on the synchronization in xml format by selecting the 
Synchronization has completed arrow. You can also save the report to the 
clipboard.

If the synchronization fails, an error report is produced, and can be accessed 
by clicking Last Run Report on the Task Summary screen.

2. Click OK to dismiss the Progress window when the task has finished 
running.

To run a full synchronization:

1. Select the task, and click File > Execute Now > Full Synchronization.

A Progress window is displayed with details of the synchronization.

You can view a report on the synchronization in xml format by selecting the 
Synchronization has completed arrow. You can also save the report to the 
clipboard.

If the synchronization fails, an error report is produced, and can be accessed 
by clicking Last Run Report on the Task Summary screen.

2. Click OK to dismiss the Progress window when the task has finished 
running.
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Disable a synchronization task

You can also disable the scheduling of a synchronization task at any time.

To disable a synchronization:

1. Select the synchronization task, and click File > Disable Scheduling.

2. Click OK.

The synchronization task is disabled.

Enable a synchronization task

You can also enable a synchronization task at any time.

To enable a synchronization task:

• Select the synchronization task, and click File > Enable Scheduling.

The synchronization task is enabled.
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1 Turning logging off and on

Rational DOORS for HP Quality Center Interface is installed with logging 
turned on by default.

What do you want to do?

• Turn off logging

• Turn on logging

• Clear old log files

Turn off logging

To turn off logging:

1. Open the Registry Editor.

Click Start > Run, type regedit, and click OK.

Note  You must be logged on as an administrator or a member 
of the Administrators group in order to perform this 
procedure.

2. Navigate to the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\TDIntegration\WebService\

3. Select the string value LogLevel, and double-click.

If the string value does not already exist, right-click New > String Value 
and enter LogLevel.

The Edit String window is opened.

4. Enter 0 in the Value data field and click OK.

Logging is switched off.

Turn on logging

To turn on logging:

1. Open the Registry Editor.

Click Start > Run, type regedit, and click OK.
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Note  You must be logged on as an administrator or a member 
of the Administrators group in order to perform this 
procedure.

2. Navigate to the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\TDIntegration\WebService\

3. Select the string value LogLevel, and double-click.

If the string value does not already exist, right-click New > String Value 
and enter LogLevel.

The Edit String window is opened.

4. Enter -1 in the Data field and click OK.

5. Select the string value LogPath, and double-click.

If the string value does not already exist, right-click New > String Value 
and enter LogPath.

The Edit String window is opened.

6. Enter a location in the Value data field and click OK.

The default location for LogPath is IWS Logs in the home directory of the 
web service. The log file is named IWS-<timestamp>.log, where 
<timestamp> is a UTC milliseconds timestamp.

7. Select Registry > Exit to close the registry.

Logging is switched on, and the location of the log file is set.

Clear old log files

If you switch on logging, each time the aspnet_wp.exe process restarts, a new 
log file is created. Clear out old log files regularly, otherwise the performance of 
your system may be adversely affected.

Navigate to the folder containing the log files, and delete any obsolete log files.



Using Rational DOORS for HP Quality Center Interface     i

1 Troubleshooting

You can resolve common problems associated with the configuration and 
operation of the Rational DOORS for HP Quality Center Interface.

What do you want to learn about?

• Security policies

• Configuration tool problems

• Connection failure

• Gathering the virtual folder structure

• IIS must include the .asm MIME type

• Timer Service problems

• Test connection fails after upgrade

Security policies

Windows security policies, such as “Deny Log on as Service,” “Deny logon 
locally,” and “Impersonate client after authentication,” can prevent users from 
logging in and registering processes.

In the Windows Control Panel, click Administrative Tools > Local Security 
Policy. In the Local Security Setting window, click Security Settings > Local 
Policies > User Rights Assignment.

The following policies can cause problems:

• Deny log on as Service: Determines which service accounts are prevented 
from registering a process as a service.

• Deny log on locally: Determines which users are prevented from logging 
on to the computer.

• Log on as a service: Determines which service accounts can register a 
process as a service.

• Log on locally: Determines which users can log on to the computer.

If a user does not belong to the Log on as service and Log on locally policies, 
then that user cannot register a process as a service and start the service. As a 
result, the user cannot register and start the Rational DOORS for HP Quality 
Center Interface Timer Service.
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Local Administrator users belong to Log on as a service and Log on locally 
policies. Use local Administrator user credentials for the Set Access Permissions 
configuration tool. Local Administrator users can register and start the Timer 
Service.

Configuration tool problems

Windows directory access

On Windows 2008 64-bit server, TrustedInstaller owns the Windows directory 
and subdirectories. The Set Access Permissions configuration tool might fail on 
these folders. Unlike Windows Server 2003, manually adding the IWUSER to 
failing folders does not resolve the problem.

In Windows Server 2008 32/64 Bit .Net Framework v2.0.50727, the 
Administrators Group is installed and granted security permission by default. 
Users might not be able to provide access permission in the Set Access 
Permission configuration tool or in the .Net Framework v2.0.50727 user 
interface. To avoid these permission problems, use local Administrator user 
credentials for the configuration tool.

TDI services configuration failure

When testing the TDI services in the Set Access Permission configuration tool, 
an error 401 (unauthorized) might occur. To resolve this problem, 
try the following fixes:

• Enable ASP.NET impersonation for web site. In the web.config file in the 
doorstdiservices folder, add the following entries:
</compilation>
<trust level="Full" /> 
http://support.microsoft.com/kb/942043/ 

• Add .asmx as a registered MIME type (text/plain) in Internet Information 
Services (IIS) 7.

• Enable Windows Authentication in IIS:

To enable Windows Authentication in IIS 6:

i. Start IIS Manager or open the IIS snap-in.

ii. Expand server_name, where server_name is the name of the server, 
and then expand Web Sites.
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Configuration tool problems

iii. In the console tree, right-click the Default Web Site, and then click 
Properties. 

iv. In Properties window, click the Directory Security or File 
Security tab. Under Authentication and access control, click 
Edit.

v. In the Authenticated access section, select the Windows 
Integrated Authentication check box.

vi. Click OK twice.

To enable Windows Authentication in IIS 7:

i. Start IIS Manager or open the IIS snap-in.

ii. Expand server_name, where server_name is the name of the server, 
and then expand Sites.

iii. In the console tree, right-click the Default Web Site. If Content 
View is shown in right panel, click Switch to Features View.

iv. Double-click Authentication.

v. Right-click on Windows Authentication and select Enable.

vi. Close IIS Manager

SOQ web service configuration failure

The Server configuration page of the Set Access Permission configuration tool 
might fail and display a red exclamation mark or the following error:

Configuring SOQ WebService

Failure - System.Runtime.InteropServices.COMException 
(0x80040154): Retrieving the COM class factory for component 
with CLSID {A440BD76-CFE1-4D46-AB1F-15F238437A3D} failed due to 
the following error: 80040154.

To resolve these problems, register the capicom.dll file:

1. In Windows, click Start > Run.

2. Type: regsvr32 <capicom.dll path>
For example, regsvr32 “C:\Windows\system 32\capicom.dll”

If the capicom.dll file does not exist in C:\Windows\System32, download it 
from the Microsoft Support web site and place it in C:\Windows\System32.
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Connection failure

If the HP Quality Center Connectivity add-in is not installed, the connection to 
HP Quality Center fails and displays the error: Data provider failed to 
initialize. In this case, the user can access the Quality Center directly, but the 
test connection fails.

To resolve this problem, register the HP ALM client.

To register HP ALM for HPQC10:

1. Open Internet Explorer and browse to the HPQC10 URL at 
http://<QCServerName:8080>/qcbin/

2. Click the Add-Ins page link. The HP ALM Add-Ins page opens in new 
Internet Explorer window.

3. Click the HP Quality Center Connectivity link.

4. After the link opens, open this URL: 
http://<QCServerName:8080>/qcbin/start_a.htm?common=true

To register HP ALM for HPQC11/11.50:

1. Open Internet Explorer and browse to the HPQC 11/11.50 URL: 
http://<QCServername:8080>/qcbin/

2. Click the Add-Ins page link. The HP ALM Add-Ins page opens in new 
Internet Explorer window.

3. Click the HP Quality Center Connectivity link.

4. Click the HP ALM Client Registration link.

5. Click the Register HP ALM Client and Register HP ALM Site 
Administration Client links, one at a time.

Gathering the virtual folder structure

On the “Gathering the virtual folder structure” page of the Set Access 
Permission configuration tool, sometimes the hostname/IWSUSER account is 
displayed in the Web Site field, rather than the default web site. If you hover 
over the red exclamation point, an error is displayed: Unable to locate 
services within the specified Web Site.

Active Directory (AD) is used to fetch web site details. Local Administrator users 
have permission and access in all directories. Use local Administrator credentials 
for Set Access Permissions. Users that do not have these credentials are not able 
to fetch desired default web site details.
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IIS must include the .asm MIME type

IIS must include the .asm MIME type

MIME is a standard that classifies resources and provides information to 
programs about how to handle them. This allows the correct handling and 
interpretation of different type files by programs.

To ensure that the configuration tool has access to .asm files and can successfully 
complete the configuration, add the .asm MIME type to Internet Information 
Services (IIS). 

To add the .asm MIME type in IIS 6:

1. Open IIS Manager and open the properties of the IIS node.

2. Click MIME Types, and click New.

3. Use the following values:
Extension: .asm
MIME Type: text/plain

4. Click OK.

To add the .asm MIME type in IIS 7:

1. Open IIS Manager and select the IIS node.

2. Double-click MIME Types on the right pane.

3. Click Add.

4. Use the following values:
Extension: .asm
MIME Type: text/plain

5. Click OK.

You can find MIME Type details at http://support.microsoft.com/kb/936496.

Timer Service problems

The Timer Service for Rational DOORS for HP Quality Center Interface might 
encounter configuration problems based on a security policy setting.

To verify that the configuration user is not listed in the Deny log on as service 
security policy:

1. Click Control Panel > Administrative Tools > Local Security Policy.

2. In the Local Security Policy window, in Security Settings, click Local 
Policies > User Rights Assignments.

3. Double-click Deny log on as a service.
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Test connection fails after upgrade

After you upgrade Rational DOORS, the connection test in the configuration 
tool might fail. This occurs because some files that are required for the Rational 
DOORS for HP Quality Center Interface, such as .dxl and .inc files, are not 
copied to the upgraded installation. 

An error is displayed: The data provider failed to initialize.

The log file contains the following entry:

“Could not start DOORS.: -E- DXL: <C:\Program 
Files\IBM\Rational\DOORS\9.5/lib/dxl/batchStartupFiles/tdintegr
ationBatchStartup.inc:13> could not open include file 
(addins/doorstdint/startup.inc) (No such file or directory)”

To resolve this problem, uninstall Rational DOORS for HP Quality Center 
Interface and reinstall it, so all the required files are installed in the folder 
structure.
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1 Contacting support

This chapter contains the following topics:

• Contacting IBM Rational Software Support

• Prerequisites

• Submitting problems

• Other information

Contacting IBM Rational Software Support

If the self-help resources have not provided a resolution to your problem, you 
can contact IBM Rational Software Support for assistance in resolving product 
issues.

Note  If you are a heritage Telelogic customer, you can go to 
http://support.telelogic.com/toolbar and download the 
IBM Rational Telelogic Software Support browser toolbar. 
This toolbar helps simplify the transition to the IBM Rational 
Telelogic product online resources. Also, a single reference 
site for all IBM Rational Telelogic support resources is 
located at 
http://www.ibm.com/software/rational/support/telelogic/

Prerequisites

To submit your problem to IBM Rational Software Support, you must have an 
active Passport Advantage® software maintenance agreement. Passport 
Advantage is the IBM comprehensive software licensing and software 
maintenance (product upgrades and technical support) offering. You can enroll 
online in Passport Advantage from 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html.

• To learn more about Passport Advantage, visit the Passport Advantage 
FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_
quickguides.html.

• For further assistance, contact your IBM representative.

To submit your problem online (from the IBM website) to IBM Rational 
Software Support, you must additionally:
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• Be a registered user on the IBM Rational Software Support website. For 
details about registering, go to http://www.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.

Submitting problems

To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a 
problem to IBM, you are asked to supply a severity level. Therefore, you 
need to understand and assess the business impact of the problem that you 
are reporting.

Use the following table to determine the severity level.

Severity Description

1 The problem has a critical business impact: You are unable to 
use the program, resulting in a critical impact on operations. 
This condition requires an immediate solution.

2 This problem has a significant business impact: The program 
is usable, but it is severely limited.

3 The problem has some business impact: The program is 
usable, but less significant features (not critical to 
operations) are unavailable.

 4 The problem has minimal business impact: The problem 
causes little impact on operations or a reasonable 
circumvention to the problem was implemented.

2. Describe your problem and gather background information. When 
describing a problem to IBM, be as specific as possible. Include all relevant 
background information so that IBM Rational Software Support specialists 
can help you solve the problem efficiently. To save time, know the answers 
to these questions:

• What software versions were you running when the problem occurred?

To determine the exact product name and version, use the option 
applicable to you:
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Submitting problems

• Start the IBM Installation Manager and click File > View Installed 
Packages. Expand a package group and select a package to see the 
package name and version number.

• Start your product, and click Help > About to see the offering 
name and version number.

• What is your operating system and version number (including any 
service packs or patches)?

• Do you have logs, traces, and messages that are related to the problem 
symptoms?

• Can you recreate the problem? If so, what steps do you perform to 
recreate the problem?

• Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components?

• Are you currently using a workaround for the problem? If so, be 
prepared to describe the workaround when you report the problem.

3. Submit your problem to IBM Rational Software Support. You can submit 
your problem to IBM Rational Software Support in the following ways:

• Online: Go to the IBM Rational Software Support website at 
https://www.ibm.com/software/rational/support/ and in the Rational 
support task navigator, click Open Service Request. Select the 
electronic problem reporting tool, and open a Problem Management 
Record (PMR), describing the problem accurately in your own words.

For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html.

You can also open an online service request using the IBM Support 
Assistant. For more information, go to 
http://www.ibm.com/software/support/isa/faq.html.

• By phone: For the phone number to call in your country or region, go 
to the IBM directory of worldwide contacts at 
http://www.ibm.com/planetwide/ and click the name of your country 
or geographic region.

• Through your IBM Representative: If you cannot access IBM 
Rational Software Support online or by phone, contact your IBM 
Representative. If necessary, your IBM Representative can open a 
service request for you. You can find complete contact information for 
each country at http://www.ibm.com/planetwide/.
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If the problem you submit is for a software defect or for missing or inaccurate 
documentation, IBM Rational Software Support creates an Authorized Program 
Analysis Report (APAR). The APAR describes the problem in detail. Whenever 
possible, IBM Rational Software Support provides a workaround that you can 
implement until the APAR is resolved and a fix is delivered. IBM publishes 
resolved APARs on the IBM Rational Software Support website daily, so that 
other users who experience the same problem can benefit from the same 
resolution.

Other information

For Rational software product news, events, and other information, visit the 
IBM Rational Software website on http://www.ibm.com/software/rational/.
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1 Notices

This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user’s responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to: 

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A. 

For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to: 

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
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Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice.

Any references in this information to non-IBM websites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
websites. The materials at those websites are not part of the materials for this 
IBM product and use of those websites is at your own risk.

IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact: 

Intellectual Property Dept. for Rational Software
IBM Corporation
5 Technology Park Drive
Westford, Massachusetts 01886
U.S.A.

Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us.

Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
may vary. Users of this document should verify the applicable data for their 
specific environment.
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Trademarks

Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or 
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 

If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corp., registered in many jurisdictions 
worldwide. Other product and service names might be trademarks of IBM or 
other companies. A current list of IBM trademarks is available on the Web at 
www.ibm.com/legal/copytrade.html.

Microsoft and Windows are trademarks of Microsoft Corporation in the United 
States, other countries, or both.

Other company, product or service names may be trademarks or service marks 
of others.
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